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Pre-requisites

Understanding the system

Fluency TM & Term Server (Fluency Server) services are enabled by network services on a
specific port (default is 1987). The server application then interacts with a back-end MSSQL
database server where all Terminology, Translation Units, and users are stored. If configured,
Fluency can operate on both an organization’s internal network, as well as over the internet

through a firewall.
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*FluencyFlow is an optional, web-based project management component that manages file and project workflows.

Required Server Components

Microsoft .Net 4.6 or higher
MSSQL Server 2005 (or greater) with Full-Text search

Supported Server Operating Systems

Windows Vista, 7, 8, 8.1, and 10

Windows Server 2008, 2008 R2 (All versions)
Windows Server 2012, 2012 R2 (All versions)
Windows Server 2016 (All versions)

Configuration Options

Fluency Server has been designed to scale proportionate to available hardware and software.
The included Microsoft SQL Server Express installation will support a 10GB Terminology
and Translation Memory (approx. 20 Million translation units) database. Should your
requirements exceed this size, it will be necessary to implement MSSQL Standard or greater.



Configuration Option 1:
1. For approximately 1 to 30 users.
2. Fluency Server and Database Server are on the same computer.
3. Database services provided by MSSQL SQLEXxpress.

Configuration Option 2:
1. Fluency Server and Database Server are on separate computers within the same
local network.
2. Database services provided by MSSQL SQLEXxpress or MSSQL
Standard/Enterprise.

Configuration Option 3:
1. Fluency Server load balanced cluster connects to Database Cluster.
2. Database Cluster is provided by MSSQL Enterprise.

Hardware Recommendations

The following are recommended hardware specifications. Because the server loads will
vary from organization to organization, it may be necessary to review the performance of
servers when they are under heavy load to determine if hardware upgrades are necessary.

Fluency Server and Database server on the same computer:
1. 1to 30 users
a. Dual Core CPU
b. 4 GB of RAM

Fluency Server:
1. 1to 20 users
a. Dual Core CPU
b. 2 GB of RAM
2. 20to 100 users
a. Quad Core CPU
b. 4GB of RAM

Database Server:

1. 1to 20 users
a. Dual Core CPU
b. 2 GB of RAM

2. 20to 100 users
a. Quad Core CPU
b. 8 GB of RAM
c. Raid array or other high-speed storage



Installation

High-level installation steps

1. If you don’t have an existing database server:
a. Install Database server
b. Configure Database server to allow Fluency Server connections
Create the FluencyDB database using provided script
Create database login (read/write access) for Fluency Server
Install Fluency Server
Configure the Fluency Server database connections
Install Fluency client software
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MSSQL Express Database Server Installation

1. If Microsoft.NET 4.0 (or greater) is not installed on the target server, please
install this first.

2. Run the installation program under MS_SQL_Install > MSSQL Server >
SQLEXPRADV_x86_ENU.exe (32bit Windows) or
SQLEXPRADV_x64 ENU.exe (64bit Windows).

3. Select "New Installation or add features to an existing installation™ from the
dialog.

4. "l accept the license terms.” > Next

5. Feature Selection - Select features as follows and click Next:

Feature Selection

Select the Express with Advanced Services features to install.

Setup Support Rules Features: Description:

Feature Selection

Instance Features SQL Client Connectivity SDK
Installation Rules [¥] Database Engine Services
Instance Configuration [¥] SQL Server Replication

Full-Text Search

[7] Reporting Services
Shared Features
Database Engine Configuration [] Business Intelligence Development Studio
Error Reporting [¥] Management Tools - Basic

[T] SQL Client Connectivity SDK

[¥] Microsoft Sync Framework
Redistributable Features

Disk Space Requirements

Server Configuration

Installation Configuration Rules
Installation Progress

Complete

Select All ] { Unselect All

Shared feature directory: C:\Program Files\Microscft SQL Server\

Shared feature directory (x86): C:\Program Files (x86)\Microsoft SQL Server)

<Back || Net> || cancel [




6. Instance Configuration - You may leave your database server name as
"SQLEXxpress" or you may change it to something else. > Next

7. Server Configuration > Next.

8. Database Engine Configuration - Select Mixed Mode and enter an “sa” (system
administrator) password.

; SQL Server 2008 R2 Setup o L 3

Database Engine Configuration

Specify Database Engine authentication security mode, administrators and data directories.

Setup Support Rules ¢ Account Provisioning ;| Data Directories FILESTREAM]
Feature Selection

etallofion Ritles Specify the authentication mode and administrators for the Database Engine.

Instance Configuration Authentication Mode

Disk Space Requirements (©) Windows authentication mode

Server Configuration
Database Engine Configuration
Error Reporting Specify the password for the SQL Server system administrator (sa) account. -

@ Mixed Mode (SQL Server authentication and Windows authentication)

Installation Configuration Rules Enter password: sescessee

Installation Progress

1 . o880 0000S
Complets Confirm password:

Specify SQL Server administrators -

WESTERNSTANDARD\Richard (Richard Tregaskis) SQL Server

administrators have
unrestricted access to
the Database Engine.

Add Current User ] [ Add... ] [ Remove ]

9. Error Reporting > Next
10. Complete > Finish

MSSQL Express Database Configuration

1. * This step may not be required if the database will be on the same computer as
the Fluency Server service, however, it is still recommended.

2. Locate the “SQL Server Surface Area Configuration” by going to Start >
Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server
Surface Area Configuration.

3. Once the dialog opens, select “Surface Area Configuration for Services and
Connections”.

4. Locate “Remote Connections” under SQLEXPRESS > Database Engine >
Remote Connections.



a. On the right hand side,

select “Local and remote connections”. This will

allow the Fluency Server to communicate with the database server.

Microsoft

SQL Server 2005

Help Protect Your SQL Server

A=
2y Mok
/4" Windows Server System

Minimize SQL Server 2005 Surface Area
SOL Server 2005 improves manageability and security by giving administrators more contral over t
and remote instances of SAL Server 2005. With the SOL Server 2005 Surface Area Configuration|

* Disable unused services and network protocols for remote connections.

") SQL Server 2005 Surface Area Configuration
L/ Help Protect Your SQL Server

Enable anly the services and connection types used by your applications. Disabling unused services and connections heps
protect your server by reducing the sufface area. For default seftings, see Help.

* Disable unused features of SQL Server components. Select a component and then configure its services and connections:

For new installations, use these tools to enable required features, services, and netwark protocols

default F e e b = [ wsDs By defaull, SOL Server 2005 Express, Evaluation, and Developer editions allow local
T e tances: o Tase Lok 0 IoonIand Qeabie,unutec leatles, seivices, & [3 Database Engine client connections only. Enterpise, Standard, and Workgroup ediions also listen for
Users with admiristiative privileges on Microsoft Windows Vista and later versions will no longer h Service remote client connections over TCP/IP. Use the oplions below to change the protocols

on which SOL Server listens for incoming client connections. TCP/IP is preferred over

privileges on this SAL Server installation by default. To explicitly add yourself as a SOL Server ad named pipes because it requires fewer ports to be opened across the firewall,

below link:

+ Remote Connections
@ 3 Ful-Text Search
g ® [, SOL Server Browser
@ AddNew Administrator © Loeal corections ook
(® Local and remote connections
® Using TCP/IP anly
© Using named pipes only

© Using both TCP/IP and named pipes

©

Read more about configuring the SOL Server suface area

Configure Surface Area for localhost [change computer

ﬁ Surface Area Configuration for Services and C

View by Instance | View by Component |
]
*

Surface Area Configuration for Features

0K J[ Cancel |[ appl [ Hebp

At this point, you may also want to click on each of the other “Service”
options and ensure that they are “Startup type: Automatic” and that the
“Service status:” is “Running”.

> 0K

Connection Settings Change Alert > OK

C.
d.

5. Locate the “SQL Server Configuration Manager” by going to Start > Programs >
Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration
Manager.

a. Highlight “SQL Server 2008 Services” and select SQL Server
(SQLEXPRESS) on the right hand side. Right-click and choose
“Restart”.
EEX

%7 SOL Server Configuration Manager,

File Action View

& FB 2

Help

@ SQL Server Configuration Manager {Local) State Start Mode ] Log On As
SQL Server 2005 Services rver Browser Running Automatic T AUTHOR
#- 4 SQL Server 2005 Network Configuration S fiucro Running Automatic
B 2. QL Native Client Configuration ECEE (WSDB) Running Automatic NT AUTHOR
op
Pause
Properties
Help
< >

Restart (stop and then start) selected service.



Creating the Fluency Database

1. Locate the “SQL Server Management Studio Express” application by going to
Start > Programs > Microsoft SQL Server 2008 > SQL Server Management
Studio Express.

2. The “Server name” box should now show SERVERNAME\SQLEXPRESS.
a. If it does not have any entry, click the drop down and choose < Browse
for more...>
b. Expand Database Engine and select your server.

3. > Connect

4. Now open the script located in the MS_SQL_Databases folder titled
“FluencyDB.sql”.

a. File >Open > File

b. Browse to MS_SQL_Databases > FluencyDB.sql

c. Click on the red exclamation mark, Execute or press F5.

d. You should see the following message: “DBCC execution
completed. If DBCC printed error messages, contact
your system administrator.”

5. Now that the databases have been created, you must create a login for the Fluency
Server.

a. Under SERVERNAME\SQLEXPRESS, expand Security.

b. Expand Logins.

c. Right-click on Logins and choose New Login.

d. Create a login name that you would like the web service to use by typing it
in the “Login name:” box.

e. Switch from Windows authentication to SQL Server authentication and
enter the desired password.



f.

T.. Microsoft SOL Server Management Studio Express

Uncheck “Enforce password expiration”.

File Edit View Tools Window Community Help

VY= TE

= | TRAN17\SQLEXPRESS (SQL Server 9.0,
@ [ Databases
& (23 Security
= [ Logins
% BUILTIN|Administrators
9 BUILTIN|Users
A NT AUTHORITY\SYSTEM
sa
8] TRAN17\SQL
28] TRAN17\SQLServer2008!
[ [ Server Roles
@ [ Credentials
& (3 Server Objects
& [ Replication
(3 Management

| Connection _______

3042 - WE‘ ‘

8 Scipt ~ [ Help

Login name:
© Windows authentication
@ SOL Server authentication
Password:

Confiim password:

Enforce password policy

er must char

Carticate name:
Mappes

Key name:
Server:

TRANT7\SOLEXPRESS

Connection:
WESTERNSTANDARD\administr

Default database:
Default language:

43 View connection properties

Ready

[] Enforce password expiration

ord at next logir

Fluency ]

\ |

master v

| <defauits

]

S@

& Login Properties - Fluen

A Status

Server:
TRANT7ASOLEXPRESS

Select “User Mapping” (top left corner).

In the “Users mapped to login:” pane, under the “Map” column, check

FluencyDB (or the name of the Fluency database).

i. With FluencyDB highlighted, in the “Database role membership for”

pane:
i. Check db_datareader and db_datawriter

cy

8 sciipt + [ Help

Users mapped to this login:

User
Fluency
Fluency

oooo

tempdb

Default Schema
dbo
dbo

o]}

Guest account enabled for: FlusncyTem

Database role membership for: FluencyT erm

[] db_accessadmin
[] db_backupoperator
[7] db_datareader

[V] db_datawiter

Connection: g

WESTERNS TANDARD administy | ] db_ddladmin
[] db_denydatareader

37 View on properties | |[7] dh_ b
(] db_owmer

]t secuiyodin
- [¥] public
Ready

J. You have now added the login for both the database and set its

permissions.

k. Select “Status” (top left corner)



i. Verify that “Grant” and “Enabled” are selected.

EEX

- Login Properties - Fluency

5 scipt ~ I Help

Settings

Permission to connect to database engine:
® Grant
O Deny
Login:
() Enabled
O Disabled

Status

SOL Server authentication:

eeeee

Connecl tion:
WESTERNSTANDARD\administr

2] View connect

tion properties

Feady

Cancel

> 0K

m. Close the SQL Server Manager

Install the Fluency Server Service

1. On the server that you wish to install the Fluency Server software on, navigate to the
“Fluency Server Installer” folder on the installation CD or zip file

2. Locate and run Setup.exe.

3. Follow the prompts to install the Fluency TM & Term Server software.

a.

*Note - The Fluency TM & Term Server application can be run as a service,
or as an application. Once the software is installed, the Fluency TM and Term
Server service will be registered with Windows to start automatically on the
next restart of the computer. You may disable the service and run the
application instead, but both cannot be run at the same time. For most
users, the service will be preferred.

4. Locate and run the Fluency TM & Term Server Configuration tool by going to
Start > All Programs > Western Standard. *see figure below

5. Now enter the database information from the previous steps into the Server Settings
and Security Settings configuration boxes

a.

b.

Database Server name — the name or IP address of the database server on the
network.

SQL Server Instance — If you provided a server instance name during
installation of MSSQL or MSSQL Express, then this needs to be provided
here. (example: SQLEXxpress).

*Master Cluster - If multiple instances of Fluency Server are to be run for
either load balancing or high-availability, one instance should have the “This
server is master (cluster)” option checked while the others should not. If there
is only one installation of Fluency Server, this option should be checked.
Database Username - the login created previous which has read/write access
to the database.

Database Password - the password associated with the login created
previously with read/write access to the database.

Database — the name of the Fluency database (default: FluencyDB).



g. Service Port — the network port that Fluency clients will connect to.
i. If the organization wants to grant internet-based access, this port will
need to forward through your organization’s firewall.
h. Require Approval — if checked, this indicates that all new translation memory
and terminology data that comes to the server must be approved (via Fluency
Server Tools) before it will be available to any user.

& Fluency Enterprise Site Configuration v 4.0 o[- B | |

Server Settings Security Settings

Database Servername: Server Ditabiacs Heonizne:

SQL Server Instance: DBlInstance

Y - Database Password:
|| This server is master (cluster) @ R

Database Settings Business Settings
Database: FluencyDB Service Port: 1587
Require Approval: [ | for all new entries)

FluencyFlow - Optional

Email Server: Email Port: 25
Email Login: Use SSL: []
Email Password: Send Emails from:

[ Test | ‘ Save ]

i. FluencyFlow — these settings all relate to an email server that can be used to
send out FlowFlow notifications from the system. This section is only needed
if FluencyFlow is also in use.

6. Once all the information has been supplied, click Test to ensure connectivity.
a. If the test should fail, this indicates one of the following:
i. The Fluency Server is unable to connect to the DB server
ii. The Fluency Server is unable to login into the database on the DB
server with the supplied information (most common)

7. If the test was successful, click “Save”

8. Now place the supplied “License.txt” file in the installation folder of the Fluency
Server to activate the server’s licenses.

9. Next start the Fluency Server service:

a. Click Start > Run or Windows button + R
b. Type “services.msc” > Enter
c. Locate and highlight the Fluency Server service, right-click and click on
Start.
10. To test the Fluency Server service, locate the Fluency Server Tester application by
going to Start > All Programs > Western Standard > Fluency Server Tester
a. Enter the requested information
i. Fluency Server — localhost, server’s name or IP address
ii. Login — “administrator”
ili. Password — “western” (please change this via Fluency Server Tools
after setup)
iv. Service Port: - (default 1987) the port designated in step 5.f
b. Click Test



Next Steps

1. Install the Fluency Server Tools application from the installation media to manage
users and settings.
a. Tolog in to your Fluency TM & Term server, use the information provided
above in the Test application.
2. Create logins via Fluency Server Tools for each Fluency user
a. Passwords require a minimum of 8 characters. Those 8 characters can be in
ANY language (e.g. Chinese, Arabic, etc.)
b. Fluency users can change their passwords via the Fluency Suite application in
Tools > Preferences > Fluency Server Settings (tab)
3. Distribute logins to Fluency Suite users
a. Fluency Suite logins are configured within Fluency Suite by going to Tools >
Preferences > Fluency Server Settings (tab).

Troubleshooting

Most problems can be traced to improper configuration or database settings. To enable error
logging, you must set the folder permissions to grant read/write/modify access to the
“Network Service”, of the installation path. If an error does occur and it is detectable, an
error log will then be saved out as "ErrorLog.txt" in the Fluency Server installation folder.



